Home (Главная)

Page 94 - Страница 94
Page 94
background image

Схемы переноса информации из одной базы данных в другую 95

Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "62.5",,,

1,"Проводка", " С " ) ;

Таб.ВывестиСекцию("Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
Ит.ВыбратьСубконто(ВидыСубконто.Контрагенты);
Пока Ит.ПолучитьСубконто(ВидыСубконто.Контрагенты) = 1 Цикл

Таб.ВывестиСекцию("Субконто1" ) ;
Ит.ВыбратьПериоды();
ДО = 0; КО = 0;
Доку = "";
Пока Ит.ПолучитьПериод() = 1 Цикл

Опер = Ит.Операция.ТекущийДокумент();
Если Доку = "" Тогда

Доку = Ит.Операция.ТекущийДокумент(); ДО = 0; КО = 0;

ИначеЕсли Доку о Опер Тогда

// Секцию следует выводить, только когда меняется документ.

Таб.ВывестиСекцию("Док"); ДО = 0; КО = 0;
Доку = Ит.Операция.ТекущийДокумент();

КонецЕсли;
ДО = ДО + Ит.ДО();
КО = КО + Ит.КО();

КонецЦикла;
Таб.ВывестиСекцию("Док");

КонецЦикла;

Схемы переноса информации из одной

базы данных в другую

Перенос информации из одной базы данных в другую возможен следующими

способами:

• через текстовый файл,
• через файл формата XML,
• при помощи OLE-сервера.
Перенос может отличаться по уровню детализации:
• перенос «документ в документ» — когда структура документа (значения

полей, шапка документа и его табличная часть) совпадают;

• перенос сводной информации (когда необязательно переносить всю инфор-

мацию, а достаточны сводные проводки, например по товарам со ставками

НДС 18 и 10%).

Если в процессе переброски документов перенесенные документы не желают

проводиться, скорее всего, программа инициализирует не все реквизиты в доку-
менте-приемнике, например не заполняет поля фирмы, валюты или курса валю-
ты. Если все поля перенесены корректно, то документы должны проводиться.

Кстати, при переносе расходных накладных следует помнить, что необходимо

переносить и справочник Номенклатура, и Контрагенты, а у справочника
Номенклатура может быть подчиненный справочник Единицы.