Home (Главная)

Page 82 - Страница 82
Page 82
background image

Объект ТаблицаЗначений 83

• УдалитьЗначение (<Позиция>, <Количество>),
• УдалитьВсе (),
• Сортировать {<Направление>)

у

• Принадлежит (<3начение>),
• ИзСтрокиСРазделителями (<Строка>),
• ВСтрокуСРазделителями (),
• РазмерСписка (),
• НайтиЗначение (<3начение>).
Пример использования списка значений:

// Процедура используется в обработке подбора таблицы значений.

Процедура ОбработкаПодбора(ЗначПод)
Если (ЗначПод.Вид() = "Номенклатура") Тогда

Если ЗначПод.ЭтоГруппа() = 0 Тогда

ВыбТовары.ДобавитьЗначение(ЗначПод);
ВыбТовары.ТекущаяСтрока(ВыбТовары.РазмерСписка());
Форма.УдалитьСтрокуТовара.Доступность(1);

КонецЕсли;

КонецЕсли;
КонецПроцедуры

ВыбТовары — это объект типа Список, который находится на форме диалого-

вого окна отчета.

Чтобы определить, входит ли выбранный элемент в список значений, можно

использовать следующий код (ВыбТовары — список значений):

Функция Товар(Тов)
Если ВыбТовары.РазмерСписка() = 0 Тогда

Возврат 1;

КонецЕсли;
Если ВыбТовары.НайтиЗначение(Тов) <> 0 Тогда

Возврат 1;

КонецЕсли;
Возврат 0;
КонецФункции

Объект ТаблицаЗначений

Объект ТаблицаЗначений применяется для создания динамических масси-

вов (не сохраняемых в БД), которые могут отображаться в диалоговых формах

(элемент Таблица значений). Таблицазначений создается с помощью функции
СоздатьОбъект ("ТаблицаЗначений

1 1

), либо визуально при добавлении на

форму элементов Таблица значений.

Основные функции работы с таблицей значений:
• НоваяКолонка(<Идентификатор>,<Тип>,<Длина>, <Точность>,

<3аголовок>

г

 <Ширина>, <Формат>, <Положение>);

• НоваяСтрока ();

• УдалитьСтроку {<НомерСтроки>);